The project is using an incompatible version (AGP 8.0.0-alpha08) of the Android Gradle plugin. Latest supported version is AGP 7.3.1

どういう意味なのか。このエラーメッセージ。

The project is using an incompatible version (AGP 8.0.0-alpha08) of the Android Gradle plugin. Latest supported version is AGP 7.3.1

書いているように、AGP (Android Gradle Plugin) のバージョンを 7.3.1 に下げると消えます。

ここらへんでいくつか分かりづらい部分があります。

 

■「Android Gradle Plugin のバージョン」とは

Plugin ID が


- com.android.application
- com.android.library

のバージョンになります。


// build.gradle
plugins {
  id 'com.android.application' version '7.3.1' apply false
  id 'com.android.library' version '7.3.1' apply false
}

ここのバージョンを 7.3.1 に下げるとエラーは消えます。

👉 【Plugin DSL】Android Gradle Plugin のバージョンを調べる方法 hatena-bookmark
👉 【Plugin DSL】「com.android.tools.build:gradle」の記述は不要? hatena-bookmark

 

■ Android Studio との Android Gradle Plugin の互換性

今、一般的に使われている Android Studio Dolphin | 2021.3.1 Patch 1 には、利用できる Android Gradle Plugin のバージョンに制限があります。

👉 Android Studio Dolphin | 2021.3.1  |  Android Developers hatena-bookmark

よって、8.0.0-alpha08 は使えず、7.3.1 は使える。

ということになります。

👉 Android Studio Dolphin おすすめの Gradle Plugin と Gradle のバージョン hatena-bookmark



関連ワード:  androidAndroidStudioGooglegradleIDEAJetBrainsツール評判開発